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0. Before you start 

This document will give you an overview of the source code for the example package Weather 
Station. Before you can work with it you need to set up your working environment as explained 
in the document “examplepackage_cubeide_gettingstarted”. Make sure you have read this 
document beforehand and executed all the steps to configure your STM32CubeIDE. 

This example is only executable on the 4.3- and 5.0-inch display, since the 3.5-inch display 
has neither a sensor nor an ESP32-WROOM-32 module. 

For a more detailed explanation of how the microcontroller works, please refer to the 
STM32F429 Reference Manual (RM0090) provided by STMicroelectronics. 

1. Introduction 

In this example package we will use the BME680 environmental sensor to measure pressure, 
humidity, temperature and air quality. The sensor is not connected directly to the STM32 
microcontroller but to the ESP32-WROOM-32 module. The ESP32 is as well a programmable 
microcontroller, but it also provides WIFI and Bluetooth connectivity. We will program the 
ESP32 module to retrieve the sensor data from the BME680. The STM32 will ask the ESP32 
for this data and get this via UART. Parallel, the ESP32 will act as a Webserver. A WiFi capable 
device will be able to connect to the board directly and see the sensor data in any web browser. 

The Code for the ESP32 Module is provided in the .zip-File on the www.21display.com Website 
and doesn’t need to be copied in the CubeIDE Project. 

2. Additional Requirements for this Example 

2.1 Additional required Hardware 

• FT232 USB-to-TTL Serial Converter 

• MiniBridge Female 6-pin Connector by ERNI (for an easy connection to the 1.27 mm 
programming pins of the ESP32 module) 

2.2 Additional configurations of CubeIDE 

In order to use the provided code, you have to activate 2 settings in CubeIDE Project 
properties. Click on Project -> Properties. Expand C/C++ Build and click on MCU Settings on 
the Tool Settings tab. Now set the two checkboxes: 

• Use float with printf from newlib-nano (-u _printf_float) 

• Use float with scanf from newlib-nano (-u _scanf_float) 

On the next page you can se a picture of these checkboxes. 

Topic: Weather Station CubeIDE 
Author: PARA 
Date: 30.11.2021 
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•  

2.3 Arduino IDE – ESP32 

In this example we also program the ESP32 module of our display board. For programming 
we use the Arduino IDE. Therefore, you need to download the latest version of this free 
software (for this example the version 1.8.15 was used). Some adjustments need to be done, 
so you can program the ESP32 module with this IDE. Open the Arduino IDE and open the 
preferences window with File -> Preferences. Here, you have to add the URL for the ESP32 
board manager. 

Write 
https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json 

at “Additional Boards Manager URLs:” and click OK. 

 
After restarting the IDE you need to open the Boards Manager with Tools -> Board -> Boards 
Manager…  and install esp32 by Espressif Systems. Now you should be able to select the 
ESP32 module as your board. Choose “ESP32 Dev Module”, like in the following picture. For 
this Example we used Version 1.0.6 of the ESP Boards Package.  
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To host the webpage for external devices, we will store a HTML file and an image on the built-
in flash of the ESP32 module. For this you need to install a plugin for your Arduino IDE. An 
instruction for installing this plugin can be found here: Install ESP32 Filesystem Uploader in 
Arduino IDE | Random Nerd Tutorials. 
Now you can upload external files to the SPIFFS filesystem of the ESP32 module. This is done 
by clicking Tools->ESP32 Sketch Data Upload. The files, that shall be uploaded, have to be in 
a directory called “data” in the same location as your Arduino sketch file. 

2.4 Arduino IDE – Webserver Libraries 

As we are going to implement an asynchronous webserver with the ESP32 module, so that 
you can monitor the sensor data remotely, two additional libraries are required which are not 
accessible via the Arduino Library Manager. They have to be added manually. 

We need the AsyncTCP library and the ESPAsyncWebServer library by me-no-dev which can 
be downloaded for free on GitHub. Follow the subsequent links and download each library 
code as a ZIP file. 

GitHub - me-no-dev/AsyncTCP: Async TCP Library for ESP32 

GitHub - me-no-dev/ESPAsyncWebServer: Async Web Server for ESP8266 and ESP32 

Extract each ZIP file into /”Arduino-installation-folder”/libraries/. This directory should now 
contain the two directories AsyncTCP-master and ESPAsyncWebServer-master. 

2.5 Arduino IDE- Bosch BSEC 

Bosch provides an API to access its BME680 sensor. The BSEC Software Library. This can 
be installed inside Arduino IDE. Open the Library Manager and search for “BSEC Software 
Library” by Bosch Sensortec. Install the latest version. The IDE won’t find the library files at the 
beginning. At first, you need to modify the platform.txt file of the ESP32 board. The file should 
be located at: 
C:\Users\username\AppData\Local\Arduino15\packages\esp32\hardware\esp32\version_number\ 

You need to edit the line which specifies the parameter recipe.c.combine.pattern. This should be line 
88. Replace this line with: 
recipe.c.combine.pattern="{compiler.path}{compiler.c.elf.cmd}" 
{compiler.c.elf.flags} {compiler.c.elf.extra_flags} -Wl,--start-group 
{object_files} "{archive_file_path}" {compiler.c.elf.libs} {build.extra_libs} 
{compiler.libraries.ldflags} -Wl,--end-group -Wl,-EL -o 
"{build.path}/{build.project_name}.elf" 

After a restart of your Arduino IDE, everything should be ready to work. 

https://randomnerdtutorials.com/install-esp32-filesystem-uploader-arduino-ide/
https://randomnerdtutorials.com/install-esp32-filesystem-uploader-arduino-ide/
https://github.com/me-no-dev/AsyncTCP
https://github.com/me-no-dev/ESPAsyncWebServer
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3. Upload Routine 

For uploading the whole project, a certain procedure has to be followed. At first, you 
need to erase the STM32 chip. You can do this within your STM32CubeProgrammer. 
Open the STM32CubeProgrammer and connect to the display board with the ST-
LINK/V2 debugger and with its power supply. Connect to the ST-Link and click on 
the Erasing & programming button in the left menu. Now click the tab Erase flash memory and 
click Full chip erase.  

Now you can flash the ESP32 module. For this you need to connect the USB-to-Serial 
converter with the 1.27mm pin connector to the right of the ESP32. The location and the pin 
assignments can be found on the pictures below. Pin 1 is marked with a little dot. Therefore, 
the bottom one is Pin 1. In order to connect the display board correctly to the USB-to-Serial 
converter, you need to connect three Pins (GND, TX and RX). The other Pins at the converter 
can be left floating. Note: Connect the RX pin of the connector to the TX pin of the USB-to-
Serial converter, the TX pin of the connector to the RX pin of the USB-to-Serial converter and 
one of the ground pins.  

The GP_ESP32_IO0 pin is important to the flashing process since this pin defines the boot 
mode of the ESP32 module. For flashing, this pin must be connected to ground before you 
turn on the power. This will signal the ESP32 to prepare for an upload. Then you can upload 
the external data to the SPIFFS and the sketch to the microcontroller in the Arduino-typical 
way. Between uploading the external data and flashing the sketch you need to turn the power 
off and on again. 

 

  

After uploading everything to the ESP32 turn off the power, disconnect the GP_ESP32_IO0 
pin from ground and turn the power on again. 

Now, you can program and flash the STM32 microcontroller as usual. 

GND 
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4. Explanation of Example Code 

4.1 STM32 Code 

4.1.1 Main function 

 

We will start our walk through the code at the main function since this gives a perfect overview 
of the steps that we will take. At the beginning, the hardware abstraction layer (HAL) and the 
system clocks are initialized. Then all the peripherals are initialized. A few variables are 
declared for later use. 

uart_init(); initializes the UART functionality and starts the receive interrupt functions. 
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The 5.0-inch displays need the pin PH6 to be set to high in order to enable the backlight. This 
is recognized by the define BACKLIGHT_EN which is defined in the 
global_Display_Touch_HAL.h file. After that, the display startup sequence, consisting of filling 
the buffers/layers with the color white and displaying our 2 logos, is started. 

Now the IP address of the ESP32 and the first set of weather data is retrieved. The weather 
interface is drawn in the background layer including the IP address. Now the weather data is 
drawn in the foreground layer and the function jumps into the main loop. 

In the main loop, the weather data is retrieved every second and displayed. 

4.1.2 draw_weather_interface 

 

This function uses the basic drawing functions, introduced in the example package Drawing 
Text and Images, to create the background for the display. In this example we use the two-
layer mode for the display. The background is drawn on Layer 1, since this one lays behind 
Layer 2. The data is drawn on Layer 2, as you will see later. 

Note: The display size determines the size and position of the interface by a #ifdef. 
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4.1.3 get_all_data_esp32 

 

After the command is sent to the ESP32, we immediately get the response, which is stored in 
the UART ring buffer until it is read. This reading of the response happens in the function 
get_all_data_esp32(). Since the individual values are floats, we read the four bytes, combine 
them back to a float by using the union data type and store them in a struct for the whole sensor 
data. This is done for the parameters temperature, humidity, pressure, approximate altitude 
and gas resistance. 
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4.1.4 draw_weather_data 

 

This function draws the retrieved values from the sensor as a string. Note, that this time we 
draw on Layer 2 which lies on top of Layer 1. The color format used in the two-layer mode is 
ARGB1555, therefore the color 0x7FFF is white but transparent. This is necessary, because 
otherwise we would cover the background. Only the strings for the sensor value are opaque.  

4.2 ESP32 code 

 
 
At the beginning of the Arduino code for the ESP32, we declare some variables that are 
needed. At first, we have the floats for the individual sensor values. Afterwards, we define the 
parameters for our webserver. The name of the WiFi-network generated by the ESP32 module 
is here called “Weather Station”. The password string is kept empty, because we don’t 
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establish a key protected network. But both strings can be changed as you like. The IP address 
for the webpage is stored in an IPAddress data type. We chose 192.168.0.1, but again, you 
can change this if you want to. At last, we declare an asynchronous Webserver object which 
listens on port 80. 

 
 
Let’s take a look at the setup function. It starts with setting up the Serial connection which is 
Arduino’s name for the UART connection to the STM32. Then we initialize the SPI pins, since 
the BME680 sensor is using this interface to communicate, and the sensor object iaqSensor. 
The SPIFFS filesystem also needs to be started, because the HTML page and an image for 
the page are stored there and need to be accessed. 
Next, we configure our access point with the IP address, we specified before and then open 
the network with the name stored in apSSID. You could also add a password. 

 

The second part of the setup function configures the webserver. At first, we define that when 
you type in the predefined IP address in a web browser, which means a “GET /”-request, the 
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HTML file in the SPIFFS is send to the user. In the HTML file, a java script will send every 
second multiple GET requests, asking for a new temperature, humidity, … value. These 
requests will be answered by sending the respective data. After configuration, we start the 
server. 

Now, let’s take a look at the 
loop function. 

At the beginning, the BME680 
sensor is asked if there is new 
data. If not, we start again at 
the top. If there is new data, 
we store the values in the 
respective variables. 

 

The second part of the loop function manages the 
UART communication with the STM32. If the 
ESP32 received an input, it responds depending 
on the value of the byte. 

 

5. Ideas for Exercise Project 

Here, we want to give you some suggestions how 
you could modify our example code and make 
your own little project. 

You could add little icons to the weather interface, 
which change depending of the values e.g., of the 
temperature. So that you could graphically 
indicate, if it is warm, cold, wet, … 


